Dưới đây câu lệnh cấu hình Loadbalacing cho 2 WAN.
Trong Clip, mình sử dụng file hướng dẫn có tận 3 WAN, tuy nhiên nếu bạn sử dụng 2 WAN thì mỗi phần bỏ đi một lệnh là đủ.
Lưu ý giúp mình nữa:
Thường các bạn hay đặt name cho các WAN kiểu VNPT WAN, FPT WAN, VNPT 1… thì các tên WAN mặc định mà MIkrotik đặt là pppoe-out1, pppoe-out2… bị đổi lại thành VNPT WAN, FPT WAN, VNPT 1…
Dành cho 3 WAN:
Phần 1.
Lệnh 1:
add action=mark-connection chain=prerouting connection-mark=no-mark
dst-address-type=!local in-interface=”LAN Network”
new-connection-mark=mark01 passthrough=yes per-connection-classifier=
both-addresses-and-ports:3/0
Lệnh 2:
add action=mark-connection chain=prerouting connection-mark=no-mark
dst-address-type=!local in-interface=”LAN Network”
new-connection-mark=mark02 passthrough=yes per-connection-classifier=
both-addresses-and-ports:3/1
Lệnh 3:
add action=mark-connection chain=prerouting connection-mark=no-mark
dst-address-type=!local in-interface=”LAN Network”
new-connection-mark=mark03 passthrough=yes per-connection-classifier=
both-addresses-and-ports:3/2
Phần 2:
Lệnh 1:
add action=mark-connection chain=prerouting connection-mark=no-mark
in-interface=pppoe-out1 new-connection-mark=mark01 passthrough=yes
Lệnh 2:
add action=mark-connection chain=prerouting connection-mark=no-mark
in-interface=pppoe-out2 new-connection-mark=mark02 passthrough=yes
Lệnh 3:
add action=mark-connection chain=prerouting connection-mark=no-mark
in-interface=pppoe-out3 new-connection-mark=mark03 passthrough=yes
Phần 3:
Lệnh 1:
add action=mark-routing chain=prerouting connection-mark=mark01 in-interface=
“LAN Network” new-routing-mark=route1 passthrough=yes
Lệnh 2:
add action=mark-routing chain=prerouting connection-mark=mark02 in-interface=
“LAN Network” new-routing-mark=route2 passthrough=yes
Lệnh 3:
add action=mark-routing chain=prerouting connection-mark=mark03 in-interface=
“LAN Network” new-routing-mark=route3 passthrough=yes
Phần 4:
Lệnh 1:
add action=mark-routing chain=output connection-mark=mark01 new-routing-mark=
route1 passthrough=yes
Lệnh 2:
add action=mark-routing chain=output connection-mark=mark02 new-routing-mark=
route2 passthrough=yes
Lệnh 3:
add action=mark-routing chain=output connection-mark=mark03 new-routing-mark=
route3 passthrough=yes
Cài lại bảng định tuyến (Hoặc gọi khác là đưa mỗi WAN vào từng Route). Các bạn xem Clip làm sẽ nhanh hơn dùng lệnh.
Lệnh 1:
/ip route
add check-gateway=ping distance=5 gateway=pppoe-out1 routing-mark=route1
add check-gateway=ping distance=10 gateway=pppoe-out2 routing-mark=route2
add check-gateway=ping distance=15 gateway=pppoe-out3 routing-mark=route3
Lệnh bổ trợ (Nếu chưa cài đặt).
Cài đặt NAT
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
add action=masquerade chain=srcnat out-interface=pppoe-out2
add action=masquerade chain=srcnat out-interface=pppoe-out3

source: https://sebastienizambard.net/

Xem thêm các bài viết về Công Nghệ: https://sebastienizambard.net/category/cong-nghe/

One thought on “Cấu hình Loadbalacing trên Router Mikrotik”

  • Tín Bùi Chân says:

    Cảm ơn bro đã làm Video tương đối chuẩn… Bro có thời gian làm Quản lý băng thông PCQ thật chi tiết. Như phòng nhân sự thì ít truy cập hệ thống nhiều thì dãy ip từ 10 đến 20 thì download 1Mbps nhưng upload là 512Kbps. Còn phòng kinh doanh do truy xuất nhiều thì băng thông từ Download 10M còn Upload thì 5M cho dãy ip của phòng kinh doanh là 20 đến 50…

    Đó là ví dụ nho nhỏ… Mong bạn chỉ dẫn thêm. Mình cảm ơn bạn.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>